What are the minimum system requirements?

You are here:
  • FAQ
  • General
  • What are the minimum system requirements?

DragDrop for Outlook is tested on and works with:
Windows 7, 8, 8.1 and 10 / Windows Server 2008 – 2019 and Office 2010, 2013, 2016, 2019 and Office 365.

For more specific details, including tested monthly channel builds,  check our System requirements page.

Table of Contents